X
NMS Prime
Stay informed. No spam. Just content. This is our promise.
I agree to the privacy terms. I can unsubscribe at any time.
X
Thank You!
X
NMS PRIME - Konferenz
Anzahl der Teilnehmer:
Datenschutz gelesen und akzeptiert
X
Vielen Dank!
X Sign up to comment and create new topics

Hi. After a new installation from Centos minimal, I tried to access to the URL http://IPserver:8080/admin/login but the browser display a 503 error:

Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

I checked the logs and the error is:

Thu Jun 11 01:48:34.508415 2020] [proxy:error] [pid 1858] (111)Connection refused: AH00957: FCGI: attempt to connect to 127.0.0.1:9000 (*) failed

[Thu Jun 11 01:48:34.508465 2020] [proxy_fcgi:error] [pid 1858] [client 192.168.4.88:56811] AH01079: failed to make connection to backend: 127.0.0.1

The firewall is stopped 

Also I checked the httpd service status, is a warning message:

Jun 11 06:37:46 localhost.localdomain httpd[1449]: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using localhost.localdomain. Set the 'ServerName' directive global...ss this message

Also the apache server is working OK when is used http on port 80

Any ideas?




Most Popular Post
There are no posts marked as being answered (liked) on this topic yet!!

3 Comments

  1. Hi Fernando,


    it should be fixed now. Can you please try to reinstall using this instruction: Installation with RPM


    BR,
    Ole

  2. Hi Ole Ernst

    I've been trying to install NMS Prime to always arrive to this same issue. I'm having a headless installation with the kickstarter file. You ask to use the RPM installation, but the ks automates automates it.  The RPMs I'm using are the latest in the repo,  nmsprime-*-2.5.4-1.

    Could you please elaborate a bit more on how to solve this issue?

    Thank you!


    ps:  These are the working commands used to provision the nem VM under KVM:

    sudo virt-install \
    --virt-type=kvm \
    --name NMSPrime \
    --memory 16384 \
    --vcpus=8 \
    --os-variant=rhel7.8 \
    --location=/var/lib/libvirt/boot/CentOS-7-x86_64-Minimal-1908.iso \
    --network=bridge=br0,model=virtio \
    --graphics vnc \
    --disk path=/var/lib/libvirt/images/nmsprime.qcow2,size=300,bus=scsi,format=qcow2 \
    --extra-args="ip=dhcp ks=https://repo.nmsprime.com/ks/nms.cfg"

    As the ks file only looks for an sda disk, you need to use the bus=scsi parameter.


    Also after an automated installation there is a glitch to secure the DB after the first boot. You need to check the generated PW for the root user under /etc/nmsprime/env/root.env

    [root@nms ~]# cat /etc/nmsprime/env/root.env
    # only place mysql root credentials in this configuration file
    # only root:root will have read/write permissions on this file


    ROOT_DB_HOST=localhost
    ROOT_DB_DATABASE=nmsprime
    ROOT_DB_USERNAME=root
    ROOT_DB_PASSWORD=xxyyzzaassdd

    to be able to run:

    mysql_secure_installation

    This issue is also present in the installation video but the solution was left out of it between 9:46 and 9:48


  3. Hi Ole Ernst, thank you for the url change in the RPM install page, now it works like a charm.